You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

32 lines
861 B

  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # This file was extended to incorporate a Meson/Ninja build system.
  9. # Uncomment this to turn on verbose mode.
  10. #export DH_VERBOSE=1
  11. %:
  12. dh $@
  13. override_dh_auto_clean:
  14. rm -rf debian/build
  15. override_dh_auto_configure:
  16. mkdir -p debian/build
  17. cd debian/build && meson --prefix=/usr ../..
  18. override_dh_auto_build:
  19. cd debian/build && ninja -v
  20. override_dh_auto_test:
  21. cd debian/build && ninja test
  22. override_dh_auto_install:
  23. cd debian/build && DESTDIR=${CURDIR}/debian/fonts-lora ninja install